Professional OPC
Development Tools

logos

× If you are developing in .NET, but are using the OPC-UA (OPC Unified Architecture), please post in the QuickOPC-UA category instead.

Can we upgrade QuickOPC 5.23 with current license ?

More
29 Jun 2017 17:51 - 29 Jun 2017 17:52 #5298 by support
Hello.

Your license has been purchased on July 21, 2015, with 1 year maintenance hat covers all versions released by July 21, 2016. Comparing that with the version table ( kb.opclabs.com/Versions ), this means that you are licensed to versions up to 5.40.

If you want to use later versions, upgrade is available for 50% of the new license price.

The reason why you are getting an error with version 2016.2 is unrelated to that. Please check the build number (e.g. by pressing the About button in the .NET demo app, or on the first page of the installation wizard). It should be 5.41.1274.1 or higher. If it's not, download the current build from our Web site, and re-install. This will give you standard trial license which gives valid data for 30 minutes every time you run the process.

Best regards
Last edit: 29 Jun 2017 17:52 by support. Reason: corrected maintenance end year

Please Log in or Create an account to join the conversation.

More
29 Jun 2017 16:33 #5297 by support
I need to be able to identify the license in order to answer these questions.

Please send me an email to support09 (at) opclabs.com, indicating either the serial number, the license key file name, or the precise date of purchase and your company name - whatever will allow us to find the details of your license.

Thank you

Please Log in or Create an account to join the conversation.

More
29 Jun 2017 16:20 #5296 by Damian999
Can we upgrade QuickOPC 5.23 with current license ?

We have a site license purchased in 2015.

All-purpose stations: Infinite
Release Date covered: 2016-07-21 01:00:00
Type: Professional; Site License

We downloaded and installed QuickOPC 2016.2, then installed same license file.

When examining a EasyDAItemChangedEventArgs parameter in debug we got the following message.

"Not allowed to run by the license. You might be using a trial license, and the version of the software you are using is obsolete. Obtain a recent version to resolve this problem.\r\nComponent name: \"QuickOPC\", license ID: \"Multipurpose\", version number: 541, release date: 2016-12-01, trial validity: 210 days, option name: \"EasyDAClient\"."

Do we need to purchase a new license to start using QuickOPC 2016.2?

With our existing license can we upgrade from 5.23 to 5.35?


Thanks,
Damian

Please Log in or Create an account to join the conversation.

Moderators: support
Time to create page: 0.164 seconds

      

 Recommend this on Google