Professional OPC
Development Tools

logos

Online Forums

Technical support is provided through Support Forums below. Anybody can view them; you need to Register/Login to our site (see links in upper right corner) in order to Post questions. You do not have to be a licensed user of our product.

Please read Rules for forum posts before reporting your issue or asking a question. OPC Labs team is actively monitoring the forums, and replies as soon as possible. Various technical information can also be found in our Knowledge Base. For your convenience, we have also assembled a Frequently Asked Questions page.

Do not use the Contact page for technical issues.

Error "Class not registered"

More
21 Feb 2014 14:37 #1748 by support
I am glad it works.

Although I cannot yet know the precise reason to the detail, I think we can safely conclude that the problem is with 64-bit registration of the DeltaV OPC Server, or OPCEnum. All other clients you have tried run as 32-bit processes and that's why they work.

Please Log in or Create an account to join the conversation.

More
21 Feb 2014 14:26 #1747 by Astolfi
Ok Resolved!

I have compiled the application for x86, I'm confused, I thought I had already tried to compile my application for x86 but I only tried with the option AnyCpu.

Thanks

Luca Astolfi

Please Log in or Create an account to join the conversation.

More
21 Feb 2014 10:41 #1738 by support
Thank you. Now, this was probably with the Demo app, right? May I ask you to try with CLSID once again, now with either your app, or the Demo app (it is in the Examples solution), but built for x86 target?

Please Log in or Create an account to join the conversation.

More
21 Feb 2014 10:33 #1735 by Astolfi
same error
Attachments:

Please Log in or Create an account to join the conversation.

More
21 Feb 2014 10:25 #1730 by support
Are you saying that with the CLSID, it gives precisely the same error ("Class not registered"), or something different? Note: this is very important to answer correctly, otherwise our analysis would go completely wrong way.

Please Log in or Create an account to join the conversation.

More
21 Feb 2014 07:32 #1729 by Astolfi
Hi

I've already tried with the ClassID instead of the ProgID, but it does not work, there is a possibility for logging actions. NET library?

thanks

Best Regards
Luca Astolfi

Please Log in or Create an account to join the conversation.

More
20 Feb 2014 19:50 #1727 by support
OK, it may also be related to the OPCEnum component. In order to determine this, can you please try to use the CLSID instead of ProgID? To do, in your application or in the .NET-based demo, enter the CLSID in place of where you normal use the ProgID (it is marked as "Server Class" argument or field). The CLSID should be used in iys full form, i.e. with "{" at the beginning, "}" at the end, and all the dashed in between the digits etc. You should be able to copy/paste it from the server browsing dialog.


The Online Forums are the preferred way for support. If needed (e.g. if there is a confidential information that needs to be exchanged), e-mail can be used. In such case, please fill in the Contact form on the site, and I will get back to you. Even in such cases, usually the majority can be done over Online Forums, and only the confidential parts over email. We want the Online Forums fill with information that can be use of use to others.

Please Log in or Create an account to join the conversation.

More
20 Feb 2014 16:56 #1726 by Astolfi
Dear support

In order:

No, there isn't a way for install to you DeltaV Ericson.

No, I haven't try with other computer becouse i can't access phisically on the machine.


progrid and classID

The question of "machine name" is really strange, with EasyOPCDADemo.exe (com version) I'm able to connect only if i leave the "machine name" empty,but if I use "localhost" or the Netbios Name I receive the same error "Class not registred"






I can browse the OPC servers with EasyOpcNetDemo.exe (see attachment:1) but when i try to read an item or make a browse of tag I have received the same error "Class not registred"


I reinstall the core components.... but still not work.

There is an other way of support ( phone or email) ?

Thanks for all


Best regards
Luca Astolfi
Attachments:

Please Log in or Create an account to join the conversation.

More
20 Feb 2014 15:25 #1725 by support
A bunch of questions here please...

Is there any way we can obtain and install the DeltaV server to test it out here? (probably not... just asking).

Have you tried this on more than one computer, and if so, what were results?

What is the ProgID you are using to connect to the server?

Are you using an empty string in place of "machine name" when referring to the local computer, ro are you using something different (such as "localhost")?

From the .NET-based demo app, are you able to browse the OPC servers including the DeltaV server? What kind of information does it display for it?

I still suspect that there may be relation to 64-bits, although you seem to indicate to the contrary. Can you please reinstall the latest *64-bit* OPC Core redistributables, from www.opcfoundation.org/DownloadFile.aspx?CM=3&RI=821&CN=KEY&CI=286&CU=12 ?

Thank you

Please Log in or Create an account to join the conversation.

More
20 Feb 2014 08:09 #1715 by Astolfi
Hi

Windows 7 64 bit Pro SP1
OPC server is Local

I have tried to compile my application for 64 bit and also for x86 but not work, my application use:

Imports OpcLabs.EasyOpc.DataAccess
Imports OpcLabs.EasyOpc

And these classes:

EasyDAClient()
ServerDescriptor()
DAItemGroupArguments()
DAGroupParameters()
DAItemDescriptor()

My application is configured for polling and datachange but any combination of these method not work.
I have tried also to connect with EasyOpcNetDemo.exe but not work

if you need other information, all you have to do is ask.

Thanks

Best Regards
Luca Astolfi

Please Log in or Create an account to join the conversation.

Moderators: support
Time to create page: 0.076 seconds