Professional OPC
Development Tools

logos

Online Forums

Technical support is provided through Support Forums below. Anybody can view them; you need to Register/Login to our site (see links in upper right corner) in order to Post questions. You do not have to be a licensed user of our product.

Please read Rules for forum posts before reporting your issue or asking a question. OPC Labs team is actively monitoring the forums, and replies as soon as possible. Various technical information can also be found in our Knowledge Base. For your convenience, we have also assembled a Frequently Asked Questions page.

Do not use the Contact page for technical issues.

Permanent license recognized as Evaluation license

More
26 Sep 2023 15:12 #12238 by Quaintly3296
thank you for the quick response.

we will use option 5 as it fits best for our infrastructure.
would be great if this option of converting the txt license to bin would be mentioned in the documentation ( Ref ).

Thank you very much

Please Log in or Create an account to join the conversation.

More
26 Sep 2023 14:46 #12236 by support
Hello.

Well, in our view, "file is a file is a file", so when we provide a license key file with some contents, we expect that the file contents should not change. But I see your point of view, and in reality, no matter whether is is technically a bug or not, we have recognized it as a problem. And it is already solved in QuickOPC 2023.1.

You have multiple options to deal with it now:
1. Use QuickOPC 2023.1+.
2. Extract the uncorrupted files from your email and configure your system to leave them uncorrupted.
3. If you cannot get hold of the uncorrupted files: Let me know and I will resend them to you, zipped.
4. Or, let me know and I will send to you the .BIN, binary version of the license key(s).
5. You can also use Base64 decoder (many available, also online), apply it to the marked up part of the .TXT license key you have, store the result to .BIN file, and use it as license key with QuickOPC.

Best regards

Please Log in or Create an account to join the conversation.

More
26 Sep 2023 08:14 #12234 by Quaintly3296
Hi, we have the same problem - the license file you provide is a .txt file, so the line ending is expected to change based on the build system.
We tried to rename the license ( remove the .txt ) to prevent line ending change, but your license manager doesnt accept anything that is not .txt

This sounds like a bug to me. you force to use the license as text file but expect it to behave like a binary file

Please Log in or Create an account to join the conversation.

More
31 Aug 2023 05:57 #12050 by support
Hello.

I have not even opened your solution, because immediately upon unzipping, I saw the problem: The license key files are NOT the files I have sent you. They are corrupted.
Something on your side, such as the email system or source controls system (we have seen that happening) has modified them. Specifically, it replaced all CR/LF pairs by a single LF.

The reason it works in version 2023.1 is because we have specifically allowed for such "damage": kb.opclabs.com/What%27s_new_in_QuickOPC_2023.1#Licensing .

I will email you the license keys anew, now zipped in an attachment. This should resolve it if the corruption is done in the email transfer. If it was done by something else, such as source control, you need to resolve the problem yourself.

Regards

Please Log in or Create an account to join the conversation.

More
31 Aug 2023 01:37 #12049 by aris
Also, I don't know if that might help but I'm using `EasyDAClient` and not `EasyUAClinet`

Please Log in or Create an account to join the conversation.

More
31 Aug 2023 01:35 #12048 by aris
I also verified that even the Evaluation key does NOT work with any version other than 5.71.334. I tried with 5.70.1352 and 5.63.246 but the evaluation key did NOT work. It worked only with version 5.71.334.

Please advise ASAP.

Please Log in or Create an account to join the conversation.

More
31 Aug 2023 01:18 #12047 by aris
I did everything that I could but this does NOT work. I followed the troubleshooting and verified both in Debug mode and using ILDASM that the resource is embedded and exists! Moreover, if the resource didn't exist RegisterManagedResourceWithExistenceCheck would have thrown an exception.

I attached the minimal reproducible example (MRE) but deleted the content of Key-Permanent-WebForm-XXX.txt license key. I have also emailed this MRE but with real keys to @opclabs.com. Please, let me know what can be wrong.

This is the MRE I'm using (the code is also attached as zip):
internal class Program
{
    static void Main(string[] args)
    {
        RegisterManagedResourceWithExistenceCheck();
    }
 
    public static void RegisterManagedResourceWithExistenceCheck()
    {
        try
        {
            LicensingManagement.Instance.RegisterManagedResourceWithExistenceCheck("QuickOPC", "Multipurpose",
                Assembly.GetCallingAssembly(),
                "OpcLabTest.Key-Permanent-WebForm-XXX.txt");
        }
        catch (CustomException customException)
        {
            Console.WriteLine($"*** Failure: {customException.Message}");
            return;
        }
 
        var client = new EasyDAClient();
        long serialNumber = (uint)client.LicenseInfo["Multipurpose.SerialNumber"];
        Console.WriteLine("SerialNumber: {0}", serialNumber);
    }
}
Attachments:

Please Log in or Create an account to join the conversation.

More
30 Aug 2023 17:33 #12046 by support

Please Log in or Create an account to join the conversation.

More
30 Aug 2023 17:10 #12045 by aris
I applied permanent license for OpcLabs 5.63 with the code below
var licenseResource = "MyProject.Key-Permanent-WebForm-XXXXXX-20210913.txt";
 LicensingManagement.Instance.RegisterManagedResourceWithExistenceCheck("QuickOPC", "Multipurpose", Assembly.GetExecutingAssembly(), licenseResource);

But, it still recognize it as Evaluation since I get again the error below
OpcLabs.BaseLib.Licensing.LicensingException: Not allowed to run by the license "Multipurpose". You might be running a trial license, and the version of the software you are using is obsolete. To resolve this problem, a) obtain a recent version, or b) ask for an evaluation license key, or c) install a license valid for the current version.
Product information follows. Component name: "QuickOPC", license IDs: "Multipurpose", version number: 563, release date: 3/21/2022, trial validity: 397 days, option expression: "EasyDAClient".
Context: 0 dropped license(s).

FYI, When I first built my project in Debug mode and checked the license type in Debug mode it said "Standard". But, when I built it in Release mode, it says now "Trial License". What am I missing here?

Here is the content of `LicenseInfo`:
{"Multipurpose.ID":"Multipurpose","Multipurpose.SerialNumber":1111111120,"Multipurpose.SubjectName":"*","Multipurpose.IssuerName":"OPC Labs","Multipurpose.NotBefore":"1601-01-01T00:00:00Z","Multipurpose.NotAfter":"1601-01-01T00:00:00Z","Multipurpose.RunTimeLimit":"00:30:00","Multipurpose.RunOnServer":1,"Multipurpose.AllPurposeStations":1,"Multipurpose.ExtraRuntimeStations":0,"Multipurpose.Type":"Trial License","Multipurpose.CallerRestrictions":[],"Multipurpose.Hidden":1,"Multipurpose.OptionRestrictions":["+StreamInsight"],"Multipurpose.PlatformRestrictions":[],"Multipurpose.ReleaseDateCovered":"1601-01-01T00:00:00Z","Multipurpose.VersionNumberCovered":563,"Multipurpose.DegradeDate":"2023-04-22T00:00:00Z","Multipurpose.IsEvaluation":1}
 

Please Log in or Create an account to join the conversation.

Moderators: support
Time to create page: 0.072 seconds