Professional OPC
Development Tools

logos

Online Forums

Technical support is provided through Support Forums below. Anybody can view them; you need to Register/Login to our site (see links in upper right corner) in order to Post questions. You do not have to be a licensed user of our product.

Please read Rules for forum posts before reporting your issue or asking a question. OPC Labs team is actively monitoring the forums, and replies as soon as possible. Various technical information can also be found in our Knowledge Base. For your convenience, we have also assembled a Frequently Asked Questions page.

Do not use the Contact page for technical issues.

Compatibility problem with Windows 10 vers. 2004

More
05 Aug 2020 14:32 #8707 by support
Thank you for the investigation you have made. (Do not use Quick Reply, it is broken).

If I understand it correctly, the problem
- does seem to strongly depend on Windows 10 version - the problem is only with Windows 10 version 2004, and
- does *not* seem to depend on QuickOPC version (version 2018.8 and 2020.2 has behaved the same).

We have Windows 2004 on some computers, but have not seen this issue yet.

Regards

Please Log in or Create an account to join the conversation.

More
05 Aug 2020 07:03 #8701 by Grizzo
Hi, yesterday evening I added a Quick Reply with some more infos, but it got lost.
They were:
1) Tried to comment the foreach loop, the app went on and PLC communication started. We had some readings and writings (more or less 1/sec) for about 10/15 second, then crashed again. I repated the same test 3 times.
2) Upgraded app to .Net Framework 4.7.1 and QuickOPC 2020.2 (last versione available I found) and reapeated the test: same result, crash after 10/15 second after communication started.

Yesterday evening I downgraded Windows back to version 1909.

This morning repeated the test, with "old" app (.Net 4.6.2 and QuickOPC 2018.3) and "new" one (.Net 4.7.1 and QuickOPC 2020.2): everything is working fine.
It is sure that the first cause is something changed in Windows 10 vers.2004 and we will warn our custmer not to upgrade Windows for the moment, but we have to solve the issue for future compatibility.

One info for you: from this point of view (Windnows version) nothing change from QuickOPC 2018.3 and newer version, 2020.2 too.

On my side, next week I will made some more trials:
1) The one suggested (makeing a simple test app)
2) Try to use app with OPC communication disabled (it can work also without connection) to see that the problem is not on our code.

The problem is that I have to prepare a new PC with newer Windows, I turned back my Windows version and i will not upgrade until solution.

Please Log in or Create an account to join the conversation.

More
05 Aug 2020 06:24 - 05 Aug 2020 06:25 #8700 by support
Hello,

regarding the question "is there any way to discover if the problem is "related to BoxedApp SDK"? ": If disabling the prerequisites boxing does not help, the issue is probably not related to BoxedApp SDK.

It is very weird that any crash happens inside the statements you have listed. They do not contain any OPC UA calls; they are simple in-memory conversions.
Can you run the program in release mode, make the crash, and then look into the Windows event log (Event Viewer -> Windows Logs -> Application) to see if there is something suspicious around the time of crash, and if so, post here the full details of the event(s)?

And, I suggest that you make a simple test program with similar code, and then run it A) with your QuickOPC version (2018.3), and B ) with current QuickOPC version (2019.2). We do not provide fixes for 2018.3, and if the same code works in 2019.2, you will most likely need to upgrade. If it still does not work with 2019.2, we will investigate further.

Best regards
Last edit: 05 Aug 2020 06:25 by support.

Please Log in or Create an account to join the conversation.

More
04 Aug 2020 07:55 #8693 by Grizzo
Hello, is there any way to discover if the problem is "related to BoxedApp SDK"? Or some other suggestions?
I tried the workarounds explained in the link, but with the same result: app crash.

To give more detailed infos:
- The crash happens when accessing UANodeElement in a foreach loop on the UANodeElementCollection returned by the EasyUAClient.BrowseObjects(...)
- The call to BrowseObjects returns correctly
- In a try/catch block there is the call to BrowseObjects and a foreach loop the logs objects infos returned
- in the loop, non exception is catched (in debug mode) and the app crashes (returns to IDE abruptly)
If in Realese Mode the app crashes and an error is logged in Windows Event Log

Example code crashing:

EasyUAClient clientOPCUA = new EasyUAClient();
UAEndpointDescriptor uadesc = new UAEndpointDescriptor();

uadesc.UrlString = host;
UANodeElementCollection uaElColl = clientOPCUA.BrowseObjects(uadesc);
foreach (UANodeElement item in uaElColl)
{
//Crashes in one of the following statements, may vary the exact statement
Console.WriteLine("OPCCHN - OPC browse node:" + item.ToString());
Console.WriteLine("OPCCHN - OPC browse node display name:" + item.DisplayName);
Console.WriteLine("OPCCHN - OPC browse node path:" + item.BrowsePath.ToString());
Console.WriteLine("OPCCHN - OPC browse node ID:" + item.NodeId.ToString());
}

Please Log in or Create an account to join the conversation.

More
04 Aug 2020 06:49 #8691 by support
Hello.

We have seen some comaptibility problems WIndows 10 version 2004. They were related to 3rd party library (BoxedApp SDK) that we use. Current version of QuickOPC has been updated to newed BoxedApp SDK which appears to work fine. There is no update for older QuickOPC versions. But, if the problems are related to BoxedApp SDK, you can try this as a workaround: kb.opclabs.com/How_to_disable_prerequisites_boxing .

Best regards

Please Log in or Create an account to join the conversation.

More
03 Aug 2020 14:47 #8690 by Grizzo
Hi, we area using EasyUAClient since 4 years without any problems on Windows 7 and Windows 10 machines (about 100).
Some days ago we upgraded a Win10Pro machine with version 1909 to version 2004 and QuinckOPC stopped to execute with exception 0xCFFFFFFFF.
No way to make it work.

I tried to upgrade also a developing machine (C# with Visual Studio 2017) from vers.1909 to 2004. In debugging mode the app crashes and VIsual Studio stops running app without any notice/tracing.
On machine with Windows 10 Pro vers. 1909 everything is working fine.

At the moment we are using library vers. 2018.3. We have not yet tried to use a more recent version because our app is not fully compatible with .NET framework 4.7. and requires some modifications.

Are you aware of compatibility problems with Windows 10 Pro version 2004? And solutions?
Thanks.

Please Log in or Create an account to join the conversation.

Moderators: support
Time to create page: 0.197 seconds