Professional OPC
Development Tools

logos

Write Not Completed error when writing with the OPC Web Client.

More
03 Feb 2015 11:16 #2676 by support
We have recently achieved a reproducible case for errors "Write not completed..." or "Read not completed...", and are working on a fix - at least for this case. It could be the same reason as yours. The fix (for version 5.32) should be available in a matter of days. It is also possible, however, that the cause in your case is different.

Regarding the "nulls" from reads - please describe what precisely is null. If, in the result object, you refer to a .Vtq property, then it is always null when .Exception property of the result object is not null. In that case, the cause of the problem is in the .Exception, and it should be examined first.

Best regards

Please Log in or Create an account to join the conversation.

More
02 Feb 2015 21:15 - 02 Feb 2015 21:36 #2671 by giles
I am getting the same error as this guy has

support.softwaretoolbox.com/app/answers/detail/a_id/1447/~/i...riting-with-the-opc-web-client .

However the settings they suggest are the defaults which I already have.

I will play with others in the factory tomorrow + look at the opc server diagnostics but wanted to flag this now.

I also sometimes get nulls from reads - I suspect this may be the same error and if so will report


I am using the kepware server talking to allen bradley ethernet
Last edit: 02 Feb 2015 21:36 by giles. Reason: changed

Please Log in or Create an account to join the conversation.

Moderators: support
Time to create page: 0.166 seconds

      

 Recommend this on Google