Professional OPC
Development Tools

logos

the service did not respond to the start or control request in a timely fashion

More
12 Jul 2014 17:37 #2069 by support
Some possibly wild ideas:

Check the user account the server is running, or perhaps use a different one.

Allow the service to interact with the desktop - it may be trying to do some UI but cannot - there is a checkbox for it.

Please Log in or Create an account to join the conversation.

More
12 Jul 2014 11:34 #2066 by Shea
You are correct, this is a problem with the target OPC server. I was able to establish a connection to a different OPC server indicating there is no problem with the OPCLabs driver or installation, and I reproduced the same behavior from a different OPC Client.

I realize that OPCLbas therefore is not at fault in this issue, but we are at a loss as to how to troubleshoot, so I would appreciate any further input you have.

I am able to talk to the malfunctioning OPC Server using the OPCLabs driver running in a process on that machine (and this process is 64-bit whereas RSLinx is 32-bit which, from our discussions before, means that it is in essence establishing a 'remote' connection if I understood correctly).

Do you have any suggestions? (I take it running the connection through OPC Analyzer wouldn't work since OPC Analyzer is unlikely to be able to establish a connection to the malfunctioning OPC Server either).

Thanks,

Shea

Please Log in or Create an account to join the conversation.

More
11 Jul 2014 18:04 #2063 by support
Yes it does. Most likely you will get the same error in any other OPC client. Unfortunately it is difficult to tell what is the reason for it, because it's server-specific.

Please Log in or Create an account to join the conversation.

More
11 Jul 2014 10:47 #2062 by Shea
The error is reported reported a notification (ItemChanged). Does this indicate a problem with the target OPC server?

Thanks,

Shea

Please Log in or Create an account to join the conversation.

More
11 Jul 2014 08:35 #2061 by support
Is it your service, using QuickOPC, that does not start?

Or is it an error from a target OPC server, reported through a notification (ItemChanged?)

Please Log in or Create an account to join the conversation.

More
10 Jul 2014 11:23 #2060 by Shea
I am getting the exception "the service did not respond to the start or control request in a timely fashion" when trying to subscribe to tags.

I don't believe this is a problem with QuickOPC as everything was working correctly prior to the server being rebooted. However, I am at a loss as to how to go about troubleshooting this.

Do you have any suggestions?

Thanks,

Shea

Please Log in or Create an account to join the conversation.

Moderators: support
Time to create page: 0.188 seconds

      

 Recommend this on Google