Professional OPC
Development Tools

logos

Online Forums

Technical support is provided through Support Forums below. Anybody can view them; you need to Register/Login to our site (see links in upper right corner) in order to Post questions. You do not have to be a licensed user of our product.

Please read Rules for forum posts before reporting your issue or asking a question. OPC Labs team is actively monitoring the forums, and replies as soon as possible. Various technical information can also be found in our Knowledge Base. For your convenience, we have also assembled a Frequently Asked Questions page.

Do not use the Contact page for technical issues.

OPC Labs Form

More
05 Sep 2021 09:03 #10182 by support
Replied by support on topic OPC Labs Form
Hello.

First, some comment on your reports and actions:
1. It is not correct that "...the error it was the same till today ...". The error message in the video is different from the one reported originally.
2. You should not use pre-release versions (5.62.0 rev6) unless specifically instructed to do so. The readme text clearly stated that.
3. And, in fact, you cannot use NuGet packages if you want to design Windows Forms with QuickOPC capabilities in them. You need to use the full installer.

So, there are multiple things wrong, and the question remains how to get to a reasonably clean state.

I suggest the following:
1. Remove all assembly references to QuickOCP assemblies from your project. The project will of course become un-buildable but that is OK at this point.
2. Uninstall any QuickOPC version you have (in Windows Control Panel).
3. In Visual Studio Toolbox, right-click, one by one, every icon under the "QuickOPC" category, and delete it, until *all* QuickOPC icons are deleted and the categioy is empty.
4. Right-click in the Toolbox area and select "Reset toolbox". If any Quick-OPC icons appear again, go back to step 2.
5. Install latest QuickOPC from www.opclabs.com/products/quickopc/downloads .
6. Open your project, and in the assembly references, add back the references to the QuickOPC assemblies (opclabs.doc-that.com/files/onlinedocs/QuickOpc/Latest/User%2...%20Assembly%20Referencing.html ).

Hopefully this will help.

Best regards

Please Log in or Create an account to join the conversation.

More
03 Sep 2021 08:13 #10177 by Paolo
Replied by Paolo on topic OPC Labs Form
Sorry, i use the 5.61.343 version for OpcLabs.QuickOpc and OpcLabs.QuickOpc.Form. After the error I tried to update at 5.62.0 rev6 version but the error remain. I tried to create a new project and several versions of the OpcLabs but the error it was the same till today as you can see in the video.

Please Log in or Create an account to join the conversation.

More
03 Sep 2021 07:25 - 03 Sep 2021 07:25 #10176 by support
Replied by support on topic OPC Labs Form
Hello.

Please answer my earlier question:

"In addition, have you have uninstalled QuickOPC and perhaps installed a new version? (the reason might be related to version clash)."

regard
Last edit: 03 Sep 2021 07:25 by support.

Please Log in or Create an account to join the conversation.

More
03 Sep 2021 06:55 #10175 by Paolo
Replied by Paolo on topic OPC Labs Form
After few days I have opened this project without any changes but the error does. Thanks for your help.
Attachments:

    2021-09-03...9-03.mp4

Please Log in or Create an account to join the conversation.

More
31 Aug 2021 14:07 #10167 by support
Replied by support on topic OPC Labs Form
Hello.

I this not clear to me at this moment this appears, and what you actually mean by "When I .... use the form ... ". Please describe the steps taken - see www.opclabs.com/forum/announcements12/2365-rules-for-forum-posts .

In addition, have you have uninstalled QuickOPC and perhaps installed a new version? (the reason might be related to version clash).

Best regards

Please Log in or Create an account to join the conversation.

More
31 Aug 2021 13:04 #10166 by Paolo
OPC Labs Form was created by Paolo
When i try to use the form from OpcLabs.QuickOpc.Forms(version 5.61.343) a pop-up with this error appears: Failed to create toolboxItem of type:

.Net Framework version 4.7.2
Attachments:

Please Log in or Create an account to join the conversation.

Moderators: support
Time to create page: 0.073 seconds