Professional OPC
Development Tools


Online Forums

Technical support is provided through Support Forums below. Anybody can view them; you need to Register/Login to our site (see links in upper right corner) in order to Post questions. You do not have to be a licensed user of our product.

Please read Rules for forum posts before reporting your issue or asking a question. OPC Labs team is actively monitoring the forums, and replies as soon as possible. Various technical information can also be found in our Knowledge Base. For your convenience, we have also assembled a Frequently Asked Questions page.

Do not use the Contact page for technical issues.

× If you are developing in .NET, but are using the OPC-UA (OPC Unified Architecture), please post in the QuickOPC-UA category instead.

Filtering nodes containing the # character.

29 Jul 2015 04:42 #3465 by idopc
ok, thanks :)

Please Log in or Create an account to join the conversation.

26 Jul 2015 15:29 #3460 by support
The vendor filter string is actually just passed through QuickOPC to the OPC server without change, and it is the OPC server that interprets the filter. Issues with vendor filter semantics are therefore likely to be issues with the OPC server, and not QuickOPC client part.

In this particular case, '#' is actually a reserved character that denotes a (decimal) digit.

You may be able to get around this interpretation by using the notation with '', possibly (but not tested):

Boiler [#]1

Note that this particular filter may be good as an example, but filtering for a well-known, single node generally is kind of useless - if you know the name of the node, you normally do not need to browse its parent for it.

Best regards

Please Log in or Create an account to join the conversation.

26 Jul 2015 15:12 #3459 by idopc
I'm evaluating the QuickOPC components and I tried the "Demo Application (OPC-DA)" sample program.
I tried to filter the branches of the "Boiler" node (In the "Browse for OPCC-DA item") you supplied in the demo server with the expression: Boiler #1

All the nodes inside the "Boilers" node disappeared.
However when I tried using the expression: Boiler *1
I kept seeing the "Boiler #1" node just as I expected.

The same happened when I tried this in my own testing program using this code:
DANodeElementCollection boilers = client.BrowseBranches("myPC", "OPCLabs.KitServer.2", "Boilers", "Boiler #1");

Is there a problem with filtering nodes containing the "#" character? is this a bug or am I doing something wrong?


Please Log in or Create an account to join the conversation.

Moderators: support
Time to create page: 0.046 seconds