Professional OPC
Development Tools

logos

Online Forums

Technical support is provided through Support Forums below. Anybody can view them; you need to Register/Login to our site (see links in upper right corner) in order to Post questions. You do not have to be a licensed user of our product.

Please read Rules for forum posts before reporting your issue or asking a question. OPC Labs team is actively monitoring the forums, and replies as soon as possible. Various technical information can also be found in our Knowledge Base. For your convenience, we have also assembled a Frequently Asked Questions page.

Do not use the Contact page for technical issues.

Error while i try to read a value with opcua

More
31 Jan 2023 19:01 #11503 by support
Hello,
not really.

Such check would be meaningless, because even if it succeeded, nobody can give a guarantee that the subsequent operation will not fail.

Best regards

Please Log in or Create an account to join the conversation.

More
31 Jan 2023 16:43 #11501 by Fietta
Hi, the machine owner discover that the problem was the machine itslef, now it works well , btw is there a command i can do to check if the machine is able to answer to my opcua command before doing the command itself (readvalue and writevalue)? Thanks

Please Log in or Create an account to join the conversation.

More
31 Jan 2023 10:55 #11500 by Fietta
Hi , an error occured qhen i try to read a value, but this error came out only yesterday, it was all right before yesterday evening, what could the problem be? Thanks

error text:

OpcLabs.EasyOpc.UA.OperationModel.UAException: An OPC-UA operation failure with error ID 'OpcLabs.UAEngine=1' occurred, originating from '' and with depth of 3. The inner exception, of type "OpcLabs.EasyOpc.UA.Engine.UAEngineException", contains details about the problem. ---> OpcLabs.EasyOpc.UA.Engine.UAEngineException: UA SDK error (Opc.UA.ServiceResult=0x80820000) in 'DiscoveryClient.GetEndpoints'. OPC UA service result - {BadTcpInternalError}. Error establishing a connection.
+ The error occurred when preselecting an endpoint for discovery URL "opc.tcp://172.16.253.6:4840".
+ Connection attempt #1; last connected at 01/01/0001 00:00:00 (local); unconnected for 00:00:00.2810000.
+ Some possible causes of this error are that the OPC-UA server is not running, or is not configured to listen on the specified port. Also, the network connection may be broken (cable unplugged?).
+ The endpoint URL string used was "opc.tcp://172.16.253.6:4840".
+ The client method called (or event/callback invoked) was 'ReadMultiple[1]'. ---> OpcLabs.EasyOpc.UA.UAServiceException: OPC UA service result - {BadTcpInternalError}. Error establishing a connection.
--> {BadTcpInternalError}. An unexpected error occurred while connecting to the server.
--> {Bad}. Impossibile stabilire la connessione. Risposta non corretta della parte connessa dopo l'intervallo di tempo oppure mancata risposta dall'host collegato 172.16.253.6:4840. ---> OpcLabs.BaseLib.Portable.CustomException: Impossibile stabilire la connessione. Risposta non corretta della parte connessa dopo l'intervallo di tempo oppure mancata risposta dall'host collegato 172.16.253.6:4840
+ This is a deducted base exception.

Please Log in or Create an account to join the conversation.

Moderators: support
Time to create page: 0.057 seconds