Professional OPC
Development Tools


Online Forums

Technical support is provided through Support Forums below. Anybody can view them; you need to Register/Login to our site (see links in upper right corner) in order to Post questions. You do not have to be a licensed user of our product.

Please read Rules for forum posts before reporting your issue or asking a question. OPC Labs team is actively monitoring the forums, and replies as soon as possible. Various technical information can also be found in our Knowledge Base. For your convenience, we have also assembled a Frequently Asked Questions page.

Do not use the Contact page for technical issues.

× The Connectivity Explorer application allows you to navigate through hierarchy of OPC Data Access and OPC Unified Architecture servers and data nodes. You can subscribe to data changes, and view the results live.

Selected data can be transferred to Excel, where it continues to stay subscribed, giving cell values that are dynamically updated with live OPC data.

Certificate is found untrusted

12 Jul 2022 09:35 #11036 by support
I am sorry that I could not reply earlier.

You are absolutely right. The problem is not related to licensing. The error message tries to hint to the likely reason - i.e. the client certificate might be in the application cert store but not in trusted peers store. The hypothesis is that this can happen when the application is first run, and it creates its own certificate, it had enough permissions to store it into the application cert store but not enough permissions to store its public copy into the trusted peers store.

Best regards
Note: Regular users cannot delete posts (but can ask us to do so if there is a good reason).

Please Log in or Create an account to join the conversation.

11 Jul 2022 20:01 #11034 by RicardoT
I wasn't sure how to remove the question. I already solved it by removing the managed certificates, then rerunning the connectivity explorer as admin. The certificates were then created correctly, this was not a licensing issue. I had found a previous post with a similar issue.

Please Log in or Create an account to join the conversation.

11 Jul 2022 19:26 #11033 by RicardoT
We have a single user license and I'm trying to transfer it to a travel laptop for testing. Is there any specific process needed to transfer it from my current pc to the travel pc? Only 1 pc will be using the license during testing but I keep getting this error see attachment, and I'm not sure if that is a licensing issue. This connection worked fine on the original pc that I started programing but gives a certificate error on the travel pc that I'm attempting to install this on.

Please Log in or Create an account to join the conversation.

Moderators: support
Time to create page: 0.046 seconds