Professional OPC
Development Tools


Online Forums

Technical support is provided through Support Forums below. Anybody can view them; you need to Register/Login to our site (see links in upper right corner) in order to Post questions. You do not have to be a licensed user of our product.

Please read Rules for forum posts before reporting your issue or asking a question. OPC Labs team is actively monitoring the forums, and replies as soon as possible. Various technical information can also be found in our Knowledge Base. For your convenience, we have also assembled a Frequently Asked Questions page.

Do not use the Contact page for technical issues.

DCOM Configuration on Windows 7

12 Jun 2014 09:06 #2041 by support
I am afraid we cannot provide much help here. The OPC connections are made using the underlying COM/DCOM infrastructure from Windows, and it is there where the error comes from. Putting together a comprehensive list of what everything must be in place would be a task that I think even Microsoft would have serious problems with.

It certainly looks like a network related issue, you are right. I have also searched the Web for the error, and there are indications that people got this when there was a problem with the name resolution, and they resolved it by adding the computer names with their IP addresses to the HOSTS file(s). I would certainly try that, or try specifying the computer names in a different form (you can use IP addresses too).

Please Log in or Create an account to join the conversation.

12 Jun 2014 05:39 #2040 by
we apologize for the delay from the last e-mail, but only yesterday we have been in the plant and could do the test what You told us last time.
In the last week, due to hardware problems, we formatted the server and the client, installed and riconfigured everything (top server, opc client, etc.) in our office (i.e. outside our customer network).

In our office the DCOM configuration were performed and worked fine, both on the server and the client; we used OPC Expert and EasyDemo to read data from TopServer and everything worked fine; also our traceability application worked fine
Yesterday our customer joined the pc server to his network; the pc client is connected to the server on a subnet (the server has two Ethernet boards). After that we had some problems when pc client reading data from Top Server:

OPC Expert could read data but gave the message " OPC Rescue was able to connect to server and could start ToolBox OPC Power Server 5.7 but could not complete the connection. Cause: this is likely because the following separates ToolBox OPC Power Server from this computer:
- NAT with "aggressive filtering"
- The Internet.

Suggested actions:
- connect this computer to Toolbox OPC Power Server using a VPN
- Remove the NAT appliances "

The IT specialist told us that there is no NAT configured and we would like not to use a VPN.

In our Application (using Quick OPC Classic 5.1 to get data from Toolbox OPC Power Server raised the exception:

OpcLabs.EasyOpc.OpcException: OPC operation failure ---> System.Runtime.InteropServices.COMException (0x80070776): the specified exporter object doesn’t exist.
in OpcLabs.EasyOpc.DataAccess.EasyDAClient.CheckComResult(Int32 hResult, IErrorInfo* pErrorInfo)
in OpcLabs.EasyOpc.DataAccess.EasyDAClient.ReadItemValue(ServerDescriptor serverDescriptor, DAItemDescriptor itemDescriptor)
in PLCManager.PLComunication.readSingleItemValue(DAItemDescriptor itemDescriptor) in C:\PLComunication.cs:riga 465 readSingleItemValue

On the server there is no firewall.

We are confident that this problem derived from our customer’s network policies (because in our office everything worked fine); so we asked out customer’s IT specialist to investigate on the message from OPC Expert but they were not able to solve it.

So can You please help us to find the real origin of the problem ? could You tell us, with some details, what verify in the network policies to remove the error on the client ?

Any suggestion is really appreciated.

We hope to hear from You soon.

Thank You very much.

Please Log in or Create an account to join the conversation.

31 May 2014 07:00 #2023 by support
For hints about error 0x80040202, see e.g.:

I would first recommend to try the same from other OPC client (on the same machine where you are deploying your client app). If you get the same error, then the problem is DCOM configuration. If other OPC clients can work well, we will look into the specifics of QuickOPC.

Version upgrades are generally available for 50% of the new license cost. More info: .

Best regards

Please Log in or Create an account to join the conversation.

30 May 2014 05:31 #2017 by
The last year we developped a Traceability application (Windows XP) in an Italian plant of our customer (automotive) and we used “QuickOPC-Classic 5.1” to get data from the Top Server.
We bought the developer+runtime license.

This year our customer migrated to Windows 7 64-bit and required an upgrading of the same application using QuickOPC 5.23 (based on Microsoft DCOM).

We have 2 questions:

1) DCOM Configuration
We got the procedure from
The procedure works well on Windows XP but doesn't work on Windows 7; we have tried it almost 20 times (both on client and server) but every time, when we use EasyOPC.NET Demo Application on the client to test data acquisition from Toolbox OPC Power Server 5.7 (which is on a separated server), we get the HRESULT Exception: 0x80040202.
Could You please indicate us the correct procedure ?
in the meanwhile it is impossible for us to release upgrated application to our customer.

2) is it possibile to get an upgrading of the upper license to work with QuickOPC 5.23 ?

Any help is appreciated.

Thank You very much.

Please Log in or Create an account to join the conversation.

Moderators: support
Time to create page: 0.060 seconds