Professional OPC
Development Tools

logos

Connected or not Connected this is a problem.....

More
02 Apr 2018 08:37 #6195 by support
Regarding possible hang: There have been fixes to similar issues in versions 2017.2 and 2018.1. First thing to do is to switch to 2018.1.

Regarding the distribution size: I have checked the current file sizes (in 2018.1). For minimal OPC UA functionality, you need the BaseLib and EasyOpcUA assemblies, they are approx. 15 MB in total (can be zipped down). This, unfortunately, cannot be realistically reduced.

Best regards

Please Log in or Create an account to join the conversation.

More
29 Mar 2018 19:56 #6194 by alr1976
Hi!

I m using 2017.1 version. Problem that i m having that After 2 days onchangenotification doesn t works anymore and i don t riceive any data and onserverstatus remain in connection.
An other problem that redistibution is about 10mb and i Need Only com version. I have a slow connection about 5kb/s so transfer 10mb is very hard to transfer.

Please Log in or Create an account to join the conversation.

More
29 Mar 2018 06:27 #6192 by support
Hello,

this may possibly be a deadlock (bug) inside QuickOPC. In such case it is unlikely that you will be able to find a workaround inside the same running process. We have, however, fixed some similar issue recently. Which precise version *and build* of QuickOPC are you running please?

Best regards

Please Log in or Create an account to join the conversation.

More
28 Mar 2018 08:23 #6190 by alr1976
Hi!

I have problem when reconnect opc ua...... Sometimes(There is no rule) Opclab try to reconnect to opc ua Server and remain in 'Connecting' and nothing happen until I close app. In Debug there is no strange log that there is a problem. So I m thinking to make a procedure to solve it but....

1) If I use
easyopcuaengine.disconnect nothing happens..... it close connection but OnServerStatus Doesn t change Status.... From 'Connected' to 'Disconnected'
and how i can reconnect it?
2)if I use UnsubscribeallMonitor and in same time I lost connection application freeze. So i need to unsubscribe Monitor before disconnect or can i only use disconnect?

Please Log in or Create an account to join the conversation.

Moderators: support
Time to create page: 0.176 seconds

      

 Recommend this on Google