Professional OPC
Development Tools

logos

Online Forums

Technical support is provided through Support Forums below. Anybody can view them; you need to Register/Login to our site (see links in upper right corner) in order to Post questions. You do not have to be a licensed user of our product.

Please read Rules for forum posts before reporting your issue or asking a question. OPC Labs team is actively monitoring the forums, and replies as soon as possible. Various technical information can also be found in our Knowledge Base. For your convenience, we have also assembled a Frequently Asked Questions page.

Do not use the Contact page for technical issues.

Error getting the item's data type when browsing OPC DA server (iFix)

More
18 Feb 2022 06:57 #10634 by support
Good, thanks for letting me know.

Best regards

Please Log in or Create an account to join the conversation.

More
18 Feb 2022 06:06 #10633 by micham
Hi,

You may close this case.

The problem was in my code. The first parameter when calling the GetDataTypePropertyValue() was "" (empty) instead of the computer name...

Thanks again for your help.

Michael

Please Log in or Create an account to join the conversation.

More
16 Feb 2022 07:19 #10620 by support
Hello,
thanks for more info. Yes, please send the screen capture form Matrikon OPC Explorer.

Do I understand it correctly that in your program, you could not browse the remote machine either, and that you had to enter the server data manually? If so, can you explain how precisely looks the piece of code that calls GetPropertyValue, and what are the values you are passing in?

The reason I am asking is that you have listed both the CLSID ({3C5702A2-EB8E-11D4-83A4-00105A984CBD}) and the ProgID in your post. QuickOPC actually allows both of them to be used at the same (using ServerDescriptor) and it will pick one of them, but you are probably passing in just the Prog|D? (which is normally OK - but CLSID might come to the rescue if there are remote browsing problems).

Regards

Please Log in or Create an account to join the conversation.

More
14 Feb 2022 16:14 #10619 by micham
Hi,

Thank you for your answer. Yes, there are 2 OPC servers, but we only connect to one of them - Intellution.OPCiFIX.1.
The OPC server is running on a remote computer and on machine that is not browsable, so we had to add it manually in Matrikon OPC Explorer.
In Matrikon OPC Explorer we can add the server, browse for items and add them to the group.
Using the EasyOPCClient we can also browse and get the item's property.

If you will look at the last screen capture that I sent you will see the full ProgId:
{3C5702A2-EB8E-11D4-83A4-00105A984CBD}

Server Class: Intellution.OPCiFIX.1

The customer added the server manually. Browsing is not available.

We took the ProgId from Matrikon OPC Explorer where we can browse and select items. I will send you a screen capture where you can see the ProgId in Matrikon Explorer.

Thank you.

Michael

Please Log in or Create an account to join the conversation.

More
14 Feb 2022 08:17 #10618 by support
Hello.

Please reply to this (repeating; parts not answered are in bold):

What I find somewhat weird is that in the screenshots, there are always two similar servers on the left side, with "Server Name" column having:

- Intellution.OPCiFIX.....
- Intellution.iFixOPC....

Unfortunately the ProgIDs are truncated at the right, so that I cannot see their full values. But what's already suspicious is the two look like work permutation on the same theme.

- Do they actually come from OPC browsing, or is the customer entering them manually?
- What are their full texts?
- Can the customer actually back his claim of the fact that it works from other OPC client(s) by a screenshot of that client, showing the successful operation AND, at the same time, the ProgID he has used in that other client? I want to rule out that the customer is, in fact, confusing the ProgID he uses in his other software, and the one he uses with yours.


Regards

Please Log in or Create an account to join the conversation.

More
14 Feb 2022 08:05 #10615 by micham
Hi,

The customer can only browse the remote OPC server tree. When he selects an OPC item and add it, he is getting this error. I have added more information to the error message. See attached.

Adding OPC items is the only required operation. If this operation fails, we can't do anything else because the item will not be added if we get an exception.

I have tried the EasyOPCClient program, I clicked on the "Browse Properties" button and got the properties without any error.

Thank you.

Michael
Attachments:

Please Log in or Create an account to join the conversation.

More
11 Feb 2022 08:32 #10612 by support
Hello.
Regarding the earlier post: at least one of EnableXXXXClient should be true; when they are both false, OPC operations will fail, that is an expected&correct behavior.

Unfortunately, the error the customer is getting now is basically the same one as before, except that is clear that you have done the change I suggested and it now comes from the other client implementation.

That leaves me wondering how this could be possible.

I am asking for the 3rd time, whether other operations from your software on the same target server work, can you/your customer provide that answer?

What I find somewhat weird is that in the screenshots, there are always two similar servers on the left side, with "Server Name" column having:

- Intellution.OPCiFIX.....
- Intellution.iFixOPC....

Unfortunately the ProgIDs are truncated at the right, so that I cannot see their full values. But what's already suspicious is the two look like work permutation on the same theme.

- Do they actually come from OPC browsing, or is the customer entering them manually?
- What are their full texts?
- Can the customer actually back his claim of the fact that it works from other OPC client(s) by a screenshot of that client, showing the successful operation AND, at the same time, the ProgID he has used in that other client? I want to rule out that the customer is, in fact, confusing the ProgID he uses in his other software, and the one he uses with yours.

Best regards

Please Log in or Create an account to join the conversation.

More
10 Feb 2022 09:39 #10606 by micham
Hi,

Our customer is now using our new build with EnableNativeClient equal False. See the attached screen capture.

Any idea what is causing this problem?

Thank you.

Michael
Attachments:

Please Log in or Create an account to join the conversation.

More
09 Feb 2022 19:39 #10598 by micham
Hi,

Thank you for your answer.
Please note that when I have changed both EnableNetApiClient and EnableNativeClient to false, I couldn't browse at all.
When I only changed EnableNativeClient to False, I was able to browse.

I have sent a new build to my customer and I'll wait for his test with his OPC DA server.

Regards,

Michael

Please Log in or Create an account to join the conversation.

More
09 Feb 2022 16:24 #10597 by support
Thank you, this clarifies it.

I have asked whether other operation on that target OPC server work - by that, I actually meant other operations *from your software*. I tend to think that they probably work. If so, the issue seems similar to me to the one we had before. That is, can you check that that EnableNetApiClient and EnableNativeClient are set in the same way on the easyDAClient object in this part code, as they are in other parts of your program?

Regards

Please Log in or Create an account to join the conversation.

Moderators: support
Time to create page: 0.105 seconds