Professional OPC
Development Tools

logos

OPCEnum does not run as service

More
19 Jul 2017 07:48 #5373 by angelaweigand
Finally we solved the situation by using DCOM and adapting the settings of the OPC Server and Clients.
We created a user account especially for OPC access and assigned this user to all OPC related applications.
Now it works reliably.

Thanks for all comments.

Please Log in or Create an account to join the conversation.

More
12 Apr 2017 12:19 #5106 by support
Actually, if you are constructing a fixed-purpose client application, and if you do not have to browse for available servers, most OPC client tools will allow you to specify the target OPC Server using its CLSID. In such case, OPCEnum is not needed at all.
The following user(s) said Thank You: angelaweigand

Please Log in or Create an account to join the conversation.

More
12 Apr 2017 10:39 #5105 by angelaweigand
You are right, i did not expect QuickOPC to install the OPCEnum Service, but finally it will need the service for accessing the OPC Server.
This does not work and so I am looking for a solution.
Since I see a very good experience with OPC in this Forum, I wondered, if anyone else has had the same effect and has got a solution for it.

Kind regards
Angela

Please Log in or Create an account to join the conversation.

More
12 Apr 2017 08:27 #5104 by support
Dear Sir/Madam,

this is a support forum our QuickOPC product. I do not see any mention of QuickOPC in your post. Are you using QuickOPC?

OPCEnum allows OPC servers to "advertise" themselves, and be discoverable by OPC clients. As such, QuickOPC does not install OPCEnum, it just uses it.

It is perfectly possible to run 32-bit services under 64-bit Windows 7, and that includes OPCEnum.

Best regards
The following user(s) said Thank You: angelaweigand

Please Log in or Create an account to join the conversation.

More
12 Apr 2017 08:16 #5103 by angelaweigand
Hi,

we have installed an Freelance OPC Server on a W2012 R2 Server 64-bit System. The OPCEnum is copied into the Windows Folder and starts running triggered by request of a remote Client.
Unfortunaly the OPCEnum is running as application and not as a Service.
The same behaviour occurs with a Win7 64-bit OS.
The OPCEnum application seems to be a 32-bit application, may this be the reason for not being registered as Service?

On a test System, we have Win7 32-bit OS, here everything runs fine...

I would appreciate any idea how to solve this problem.

Please Log in or Create an account to join the conversation.

Moderators: support
Time to create page: 0.269 seconds

      

 Recommend this on Google